Google Domain CNAME/Domain Forwarding | Community

Google Domain CNAME/Domain Forwarding

  • 28 January 2023
  • 4 replies


Hello, first time posting in here and hoping someone can answer this for me. I’ve been going crazy trying to figure this out. I’ve successfully set up previous carrot websites in the past when my domain was registered with GoDaddy. However, my newest domain was purchased on Google Domains and I’m running into issues setting up the DNS settings and domain forwarding.

If I set up the “host name” field as www, “type” field as CNAME and the “data” field as, I have no issues. However, as soon as I try to forward the domain (http://) and my (without a www. in front of it). It makes me delete the CNAME and vice versa. If I create the domain forwarding first, it works fine… but then as soon as I try to create the CNAME afterwards, it makes me delete the domain forwarding that I just completed. 

Seems as though, there’s no way to do both? I’ve followed Carrot’s google domain setup tutorial but it doesn’t work either due to the “synthetic records” tab not appearing in my Google Domains account. 

Has anyone had this issue before? Would really appreciate any advice!


4 replies

Userlevel 7
Badge +3

Hi @cailanknight and Welcome!

Google domains is a bit tricky. Can you try adding these records instead of using the forwarding section:

Type: A
Host: @

Type: TXT
Host: _redirect
Value: Redirects permanently from /* to*    (Use the whole line since it’s a text record and add your domain after www. )


Let me know how it goes and please post a screenshot if you are still having issues.

Thanks for your help with this.

Userlevel 7
Badge +3

@cailanknight Please let me know if you still need help with this.


That worked! The only thing I had to change from your suggestion was Host “@”, I just left it blank because it wouldn’t let me save it. However, everything else worked and my website is forwarding correctly now. Thanks for the help!

Userlevel 7
Badge +3

@cailanknight I’m glad that worked and you were able to switch leaving the host blank instead of adding the @ symbol. I’m not sure why Google decided to hide that feature on its platform and make it harder 😭